Back
Resolved
Resolved
Infrastructure OS Upgrade
Completed 21 Jul at 08:00am CDT.
Main Public Page
Content Check
Completed
Maintenance ended
Posted
21 Jul at 08:00am CDT.
Started
Our web site host is upgrading the operating system on their servers to ensure better performance and security. Our web site will be temporarily offline for about an hour during this time.
Posted
21 Jul at 02:00am CDT.